Android java compiler level

Android-java-compiler-level-featured.png

Android requires compiler compliance level 5.. Please fix project qualities.
Published by in Projects on Marly 16th, 2011, 7:53 am 28 comments

Within our Android mobile development class we constantly focus on projects like a class after which Dr. Liddle transmits us the up-to-date zip that contains the project to examine after our in-class additions. For whatever reason today I am getting some issues posting the Android project into Eclipse. Problems and fixes below.

Android java compiler level1 Android java compiler level

Problem #1:
Android requires .class compatibility set to five.. Please fix project qualities.

Solution:
1. Fix project:
Package Explorer ->
Right click on the project ->
&ldquoAndroid Tools&rdquo -> &ldquoFix Project Qualities&rdquo
2. Restart Eclipse:
&ldquoFile&rdquo -> &ldquoRestart&rdquo

Fix Project Qualities

Problem #2: The next error seems many occasions
The technique abc() of type ABC must override a superclass method

Solution:
Package Explorer ->
Right click on the project ->
&ldquoProperties&rdquo -> &ldquoJava Compiler&rdquo -> &ldquoCompiler Compliance Level&rdquo = 1.6

Fix Java Compiler Qualities

Problem #3: The import android.internet.http.AndroidHttpClient can’t be resolved

Solution:
Package Explorer ->
Right click on the project ->
&ldquoProperties&rdquo -> &ldquoAndroid&rdquo -> &ldquoProject Build Target&rdquo = 2.3.3

Fix Build Target